AsRock Motherboards and 2.5 external hard drives

I noticed a problem Western Digital My passport 1 TB, I could hear clicks from the drive when it’s connected to my famous Asrock x58 Deluxe, the same clicks you would hear from a bad hard drive, failing to spin-up.  I assumed that the drive is bad. but that was not right, it is working like a charm on other computers, even laptops.

The drive copy some files without errors, many people would have just listened to lady GaGa and just danced assuming the everything is gonna be Ok, but it’s not.

I checked the files that I backed up but most of them were corrupted!!!! yes corrupted, windows thought everything was ok but it wasn’t.

After investing a couple of hours of my sorry life trying to find a solution to this, I understood that the problem was that the drive is not getting enough power to be more specific the 5V delivered were not complete I tried all the following without success, :

– Changing the used port

– Unplugging eveything on the same hub

– Over clocking the board

-running the asrock power saving mode

– Upgrading the BIOS

– different file systems for the drive.

– The asrock App charger, (that is suppsed to make ipods and iphones charge faster off AsRock boards by that delivering higher voltage to them).

– Updating the Intel INF drivers.

So I dug a little deeper and here is what I discovered.

There are two Enhanced USB controllers and about 6 regular USB controllers in the chipset.

The Motherboard seems to be stacking all USB devices on the same controller, which append to be the first enhanced controller 3ACC. I think it would be safe to assume that the controller is able to deliver only a limited current, so if you have multiple high power consumption devices, you will fail to deliver enough power to everything.

In my case, I have a USB webcam sucking 500 mA, A USB WiMax modem, sucking another 500 mA, a USB printer draining around 100 mA, so when I add the external hard drive claiming an extra 500 mA, from the same poor little controller, it would be natural to have a failure.

I tried something that got me some interesting results:

I went around and disabled the rock star USB Enhanced host controller that  is gathering all usb hardware around it, and guess what? now the usb devices are distributed among hubs, and I have no power failures, and no clicks!!!

But I still have a problem, the copy speed of the hard drive went down from 30 MB /s to just a couple hundred KBs, and anytime I would re – enable the first enhanced controller, all devices would disconnect and reconnect to it as they were before.

Comments are closed.